Backup de Mikrotik

1. Habilitar Gmail para enviar correos desde aplicaciones de terceros

Lo primero que debemos hacer es habilitar la autenticación de dos pasos de nuestro correo Gmail. Diríjase al ícono con su inicial/foto de su cuenta y cliquee en "Gestionar tu cuenta de Google".

19131913

Luego Seguridad > Verificación de dos pasos.

18981898

En el campo teléfono coloque un número de celular válido, para que Google envíe un SMS y compruebe la cuenta. Luego ingrese el código recibido con formato similar a "G-12345".

18981898

De esta manera la Verificación en dos pasos figurará "Activada". Ahora deberá configurar una clave para usar en su Mikrotik desde Seguridad > Contraseña de aplicaciones.

19011901

Elija Correo y Seleccionar dispositivo > Otro.

18821882

Escriba un Nombre como por ejemplo "MIKROTIK" y cliquee "GENERAR".

18841884

Luego de esto aparecerá en pantalla una clave de 16 caracteres, que es la que usará en su Mikrotik para enviar el backup por e-mail.

18891889

2. Configurar Mikrotik para enviar e-mails a través de Gmail

Ingrese a su Mikrotik a través de Winbox Tools > Email y configure los parámetros:

534534

📘

Para encontrar su server SMTP de Gmail más cercano, realice ping smtp.gmail.com y use la IP que aparezca.

SI todo es correcto deberá poder enviar el e-mail desde el botón "Send Email"

Lo siguiente es crear la tarea programada con nuestro script de backup desde System > Scheduler:

  • Name: Backup
  • Start Date: Jun/07/2022 (revise que la hora de su mikrotik sea correcta)
  • Start Time: 01:30:00 (hora a la que se correrá el backup)
  • Interval: 1d 00:00:00 (cada cuánto se correrá el backup, en este caso es cada un día)

El resto de las opciones no se modifican.

17631763

Pegue el siguiente script en el cuadro blanco, reemplazando"[email protected]" por el e-mail que configuró en el paso 1.

log info "Iniciando respaldo"
:global backupfile ([/system identity get name]. ".rsc")
/export file=$backupfile
:log info "Creando el respaldo..."
:delay 10s
:log info "El respaldo esta siendo enviado a su correo"
/tool e-mail send to="[email protected]" subject=([/system identity get name] . \
" Backup") [email protected] file=$backupfile
:log info "Envio de respaldo finalizado"
:delay 60
/file remove ([/system identity get name].".rsc")

Finalmente recibirá un e-mail con el archivo del backup, formato .rsc

¿Consultas?
Contáctenos al chat


Did this page help you?